CL.exe not found

5 posts / 0 new
Last post
Offline
Last seen: 8 years 5 months ago
Joined: 03/08/2012
Posts: 1
CL.exe not found

when i run rtiddsgen -language C++ -example i86Win32VS2010 msg.idl in the command prompt,it display as this:

 

Running rtiddsgen version 4.5e, please wait ...
The preprocessor 'CL.EXE' cannot be found in your path.
If your IDL file contains preprocessor directives, be sure that 'CL.EXE'
is in your path or specify an alternative preprocessor through the use of the
flag -ppPath.
If your IDL file doesn't contain preprocessor directives you can disable the
use of the preprocessor using the flag -ppDisable.

Done (failures)

 

i have according to the RTI-DDS getting start.pdf to run the vcvarsall.bat in my VS2010 directory,but it show again.

please help me , thanks

 

outman

Keywords:
Offline
Last seen: 5 years 1 day ago
Joined: 10/28/2010
Posts: 22

run cmd prompt, go to C:\Program Files\Microsoft Visual Studio 10.0\VC\vcvarsall.bat 

then run the vcvarsall.bat file, then compile your idle file.

 

It should work.

Offline
Last seen: 6 years 8 months ago
Joined: 09/29/2013
Posts: 5

I've the same problem, even after I run vcvarsall.bat file. 

 

Gerardo Pardo's picture
Offline
Last seen: 1 month 34 min ago
Joined: 06/02/2010
Posts: 592

Hello, Add the parameter -ppDisable to the call to rtiddsgen as in:

rtiddsgen -ppDisable -language C++ -example i86Win32VS2010 msg.idl

 

Gerardo

Juanjo Martin's picture
Offline
Last seen: 11 months 2 weeks ago
Joined: 07/23/2012
Posts: 48

Hi community users,

As Gerardo says, using the command-line option -ppDisable you should not get that error (since the preprocessor won't be executed).

However, if you need to run preprocessor directives in your idl, you need to find out why CL.EXE cannot be found by the command prompt. I always use the command prompt that comes with Visual Studio (Visual Studio Command Prompt (2010) since it already includes the path to the preprocessor. If for any reason the preprocessor cannot be found automatically, you can add it to the PATH environment variable. For instance, in my case CL.EXE is in C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin.

You can find some information about how to modify environment variables in the following link:

http://www.computerhope.com/issues/ch000549.htm

I hope this helps,

Juanjo Martin