5.1.0 Recording Console Error

13 posts / 0 new
Last post
Offline
Last seen: 6 months 5 days ago
Joined: 10/23/2013
Posts: 38
5.1.0 Recording Console Error

I recently installed 5.1.0 and get the following error when launching the recording console.

Sorry, the RTI REcording Console does not know where to find the DDS Quality of Service configuration file.

This could be the result of an installation problem.

Please review the contents of the file settings.ini, located in your home directory, it should include an entry telling the console where to find the DDS configuration file.

The settings.ini refers to the dds_interface_qos_profiles.xml which are both in the RTI\RTI Recording Service 5.1.0\console\configurationFiles\ folder.  I looked at both of these files and they look OK and are similar to the 5.0.0 versions of the files.  Neither have been modified since the installation.

Recording Service 5.0.0 works fine.

Any idea what is going on?

Organization:
Keywords:
ken
ken's picture
Offline
Last seen: 3 months 2 weeks ago
Joined: 04/13/2011
Posts: 53

Mark,

   Can you provide the log and settings.ini files? You can get to the log file by clicking the 'i' in the lower-left corner of Recording Console and then it is listed at the bottom of the panel that appears. I can't promise I can help you resolve it this week as I'm on travel (@EclipseCon). But I'll see what I can do and I'll ask Juanlu to help out here.

Thanks,
Ken

Offline
Last seen: 6 months 5 days ago
Joined: 10/23/2013
Posts: 38

Hi Ken,

I am not able to obtain the log file.  The error message dialog opens right after launching the Recorder.  The Recorder closes immediately after I select the "OK" button on the error message dialog.

I did a full reinstall of 5.1.0 and get the same error message.  Attached are the settings.ini and dds_interface_qos_profiles.xml files.

Thanks.

Mark.

File Attachments: 
ken
ken's picture
Offline
Last seen: 3 months 2 weeks ago
Joined: 04/13/2011
Posts: 53

Hi Mark,

   Could you try renaming your settings.ini file? I'm comparing it to the one I have here and it looks different enough that I'm suspicious there may be something wrong. If that doesn't work then I think we should setup a Webex so we can debug together. Does that work for you?

Thanks,
Ken

Offline
Last seen: 1 week 2 days ago
Joined: 01/15/2013
Posts: 91

Hi Mark,

The files you provided, where they located in the installation directory of Recording Service or in your home directory (under the RTI/RTI Recording Service <version> directory)? Recording Console makes a copy of the the initial settings.ini file in the installation directory into your home directory workspace.

Thanks,

Juanlu

Offline
Last seen: 6 months 5 days ago
Joined: 10/23/2013
Posts: 38

Hi Juanlu,

Attached is the file in C:\Users\mmcbroom\Documents\RTI\RTI Recording Service 5.1.0\console.  File is identical to the version in the install directory.

 

 

File Attachments: 
Offline
Last seen: 1 week 2 days ago
Joined: 01/15/2013
Posts: 91

Hi Mark,

Is there a copy of the dds_interface_qos_profiles.xml file in your user directory?

Does the file "C:\Program Files...... Recording Service 5.1.0\console\configurationFiles\dds_interface_qos_profiles.xml" also exist?

Offline
Last seen: 1 week 2 days ago
Joined: 01/15/2013
Posts: 91

With your "user directory" I mean: C:\Users\mmcbroom\Documents\RTI\RTI Recording Service 5.1.0\console

Offline
Last seen: 6 months 5 days ago
Joined: 10/23/2013
Posts: 38

The file dds_interface_qos_profiles.xml does exist in C:\Program Files (x86)\RTI\RTI Recording Service 5.1.0\console\configurationFiles.  this file is included in the .zip file posted earlier in this thread.

There is not a copy of the dds_interface_qos_profiles.xml file in my "user directory" (C:\Users\mmcbroom\Documents\RTI\RTI Recording Service 5.1.0\console).  The only file in that directory is the settings.ini file.

Thanks.

Mark.

Offline
Last seen: 1 week 2 days ago
Joined: 01/15/2013
Posts: 91

Hi Mark,

I think that's why Recording Console is complaining. Supposedly, Recording Console should have copied that file to your user directory (Users\mmcbroom\Documents\RTI\RTI ....).

As a workaround, can you copy that file inside the directory and try to run the tool again? Let me know if it works this way.

Thanks,

Juanlu

Offline
Last seen: 6 months 5 days ago
Joined: 10/23/2013
Posts: 38

Hi Juanlu,

I copied dds_interface_qos_profiles.xml file to my "user directory" (C:\Users\mmcbroom\Documents\RTI\RTI Recording Service 5.1.0\console), but get the same error.  Any other ideas?

Thanks.

Mark.

Offline
Last seen: 1 week 2 days ago
Joined: 01/15/2013
Posts: 91

Hi Mark,

Another thing to verify: could you please show me the contents of the rtirecordingconsole.bat file in the "scripts" folder of the Recording Service 5.1.0 installation directory? There are two variables that should be set by the installer and might be a source of problems if they aren't.

Thanks,

Juanlu

Offline
Last seen: 6 months 5 days ago
Joined: 10/23/2013
Posts: 38

Hi Juanlu,

I have attached rtirecordingconsole.bat.

Thanks.

Mark.

File Attachments: