Admin Console Crashes

4 posts / 0 new
Last post
Offline
Last seen: 5 months 1 day ago
Joined: 08/13/2014
Posts: 55
Admin Console Crashes
AttachmentSize
Plain text icon Crash Logs and QoS18.25 KB

Hi everybody,

I see a lot of crashes in Admin console application theses days and I think that theses crashes is somehow related to the recent QoS changes (especially domain participant QoS). I have attached some crash logs from admin console and also all of my QoS.


I would appreciate it if anyone can help me to solve theses problems.

Bonjefir

ken
ken's picture
Offline
Last seen: 7 months 1 week ago
Joined: 04/13/2011
Posts: 53

Hello Bonjefir,

I'm Ken Brophy and I'm the developer for Admin Console. I believe the issue you're running into is ADMINCONSOLE-464 (this is an internal tracking ID). The problem occurs after ~8 domains have been joined...though it can happen earlier if you've changed the QoS used by Admin Console. This problem was fixed in the 5.2.3 version. Are you using a version earlier than that?

Thanks,
Ken

Offline
Last seen: 5 months 1 day ago
Joined: 08/13/2014
Posts: 55

Dear Ken,

Thanks for your answer. Yes, I'm using 5.2.0 version but I haven't changed the QoS used by Admin Console. (Actually I want to do that but I don't know where is the XML file using by Admin Console). Anyway, is there any way to solve the problem except upgrading to the last version?

Bonjefir

ken
ken's picture
Offline
Last seen: 7 months 1 week ago
Joined: 04/13/2011
Posts: 53

Dear Bonjefir,

I have not identified another workaround besides using the latest version. The issue in question has not been reproduced outside of the 5.2 build (neither 5.0 nor 5.1 show the issue and the logic for this codepath has not changed). 

You can adjust the QoS settings used by Admin Console through the Preferences/Settings dialog. In the Admininstration section, there are controls to add new QoS files and then choose which QoS library/profile gets used. Please use caution when doing this as Admin Console uses a number of non-standard settings for different Topics. You're best bet is to start with the example Admin Console QoS file which is shipped with every release. You can find this file in <install>/resource/xml/admin_console_example_profiles.xml. 

Let me know if you have any trouble with this and we can do a WebEx.

Thanks,
Ken