Error on Install

4 posts / 0 new
Last post
Offline
Last seen: 10 months 1 week ago
Joined: 01/19/2021
Posts: 2
Error on Install

I am trying to install the RTI DDS Toolkit for LabVIEW 2020 and it gets going through the install and stops with an error.  It tells me that there is a custom error that i "may need to run LabVIEW or VIPM with Administration Privileges".  If I close down the VIPM and reopen running it as administrator it still does the same thing on install.  I cannot find any info on how to remedy this issue on install.  Anyone have any ideas?

Offline
Last seen: 7 months 2 weeks ago
Joined: 04/23/2014
Posts: 51

Hi CamBuf, can you try to close LabVIEW as well? I mean, LabVIEW and VIPM are closed, then run VIPM with administration privileges. The problem is that if LabVIEW stays open, it will use the privileges that it had, therefore it won't inherit the admin privileges from VIPM.

Offline
Last seen: 10 months 1 week ago
Joined: 01/19/2021
Posts: 2

angel, I just decided to restart and close down LabVIEW and everything else this morning (again) and try it.  And now it worked.  So you were right.  I guess the shut downs I did yesterday did not shut everything down.  Thanks for the input!

Ismael Mendez's picture
Offline
Last seen: 2 days 3 hours ago
Joined: 07/03/2017
Posts: 36

Hi CamBuf,

I have seen a similar issue with VIPM 2019. It seems that some service is affected and remains opened after failing the first time due to not running as Administrator. Have you tried to run as Administrator after restarting Windows?