I configured multicast to use a custom IP multicast address but am still seeing the 239.255.0.1 address every minute

4 posts / 0 new
Last post
Offline
Last seen: 6 months 3 weeks ago
Joined: 05/21/2014
Posts: 46
I configured multicast to use a custom IP multicast address but am still seeing the 239.255.0.1 address every minute

I followed the tortial posted on the RTI DDS website to configure the multicast address to use, however when I do a wireshark trace I see the following about every minute

192.168.x.x 239.255.0.1 UDP 698 Source port: 56511  Destination port: rtps-discovery7400

Why is the 239.255.0.1 IP address still being used every minute even if I configured the multicast to use a different address?

rip
rip's picture
Offline
Last seen: 25 min 12 sec ago
Joined: 04/06/2012
Posts: 322

Not an answer, but may point to one:

What version of Connext are you using?

Later versions have a 'subvocal' whisper announcment that allow the GUI tools to know which domain a participant is running on.  Previous versions of the tools you had to configure for the domain to inspect, later versions of the Participant sends a simple message to domain 0 to say "I'm on 112".

That would only work if it both used Domain 0, as well as the default multicast address.

 

Offline
Last seen: 2 years 10 months ago
Joined: 09/17/2015
Posts: 53

Where did you set it? Enable DDS logs and check which addresses your application really uses. There exist several bugs with setting multicast addresses.

Gerardo Pardo's picture
Offline
Last seen: 3 weeks 4 days ago
Joined: 06/02/2010
Posts: 594

Are you using 5.2.3? There is a new feature in this version that will produce additional default announcements on the default RTPS multicast address and the port for domain 0 (7400) in addition to the regular domain-specific port and configuration. This is intended to help debugging tools and it is enabled by default.

You can disable it by setting the DiscoveryConfigQosPolicy. See https://community.rti.com/static/documentation/connext-dds/5.2.3/doc/api/connext_dds/api_cpp/structDDS__DiscoveryConfigQosPolicy.html#a2752eac191f6864b08436ca1064e8a01

Maybe we should automatically disable this "default announcement" if the application disables multicast. But the issue is that the multicast setting is meant to apply to the transports used by yout participant/domain and this is more of an out-of-band ping to detect the presence of domains. This is why the rate is configured separately from that of the regular participant announcements.

Gerardo