ignore participant of dynamic data

2 posts / 0 new
Last post
Offline
Last seen: 5 years 1 month ago
Joined: 05/26/2015
Posts: 2
ignore participant of dynamic data

hi all,

I have created a dynamic data publisher and subscriber, but i want to ignore the local participant from receiving the publisher's data. How can I do it?

Offline
Last seen: 1 month 16 hours ago
Joined: 05/23/2013
Posts: 50

Hi,

Do mean the "local participant" that participants running on the same machine? 
If so, please add this settings under the "participant_qos"

<!-- This disables communications via loopback -->
<property>
   </value>
      <element>
         <name>dds.transport.UDPv4.builtin.ignore_loopback_interface</name>
         <value>1</value>
      </element>
   </value>
</property>

<!-- This only allows UDP transport, so that shared memory communication is not enabled -->
<transport_builtin>
   <mask>UDPv4</mask>
</transport_builtin>