OpenSSl CNG Engine with OpenSSL3.0 Support

4 posts / 0 new
Last post
Offline
Last seen: 8 months 1 week ago
Joined: 11/03/2023
Posts: 2
OpenSSl CNG Engine with OpenSSL3.0 Support

Is there an unofficial OpenSSl CNG Engine available with OpenSSL3.0 Support?

Organization:
Keywords:
Offline
Last seen: 8 months 6 days ago
Joined: 01/14/2013
Posts: 16

Hi Divya,

No, there is not. OpenSSL 3.0 deprecated engines (see https://www.openssl.org/docs/man3.0/man7/migration_guide.html "All engine functions are deprecated."). RTI does not yet support engines' replacement (providers...see https://community.rti.com/static/documentation/connext-dds/7.2.0/doc/manuals/connext_dds_secure/users_manual/p3_advanced/openssl_engines.html "The Security Plugins do not support the OpenSSL Provider API").

Yusheng Yang (RTI)

Offline
Last seen: 8 months 1 week ago
Joined: 11/03/2023
Posts: 2

Thanks Yusheng for the quick response. Any plans of having it in the near future? 

Offline
Last seen: 8 months 6 days ago
Joined: 01/14/2013
Posts: 16

Supporting OpenSSL providers in general is on the roadmap for the near future, but CNG specifically is not on the roadmap.