RTI ME Shared Memory Example [Solved]

3 posts / 0 new
Last post
Offline
Last seen: 9 years 11 months ago
Joined: 08/28/2013
Posts: 66
RTI ME Shared Memory Example [Solved]

Hi,

I didn't find clearly how to use DDS with shared memory.
I set in source code:

*DDS_StringSeq_get_reference(&dp_qos.transports.enabled_transports,0) = DDS_String_dup("_intra");

My logs:
Subscriber:
[1382950858.880658998] TID[1300][BIND]: ADDDED 1/_intra/0/0/0
[1382950858.882659998] TID[1300][BIND]: ADDDED 2/_intra/0/0/0
[1382950858.884659998] TID[1300][ROUTE] Added interface kind=4,port=0,address=0.0.0.0,mask=0.0.0.0/128,intf=008100D8
[1382950858.905666998] TID[1300]enable participant id 449

Publisher:
[1382950861.428422999] TID[10260][BIND]: ADDDED 1/_intra/0/0/0
[1382950861.429422999] TID[10260][BIND]: ADDDED 2/_intra/0/0/0
[1382950861.429422999] TID[10260][ROUTE] Added interface kind=4,port=0,address=0.0.0.0,mask=0.0.0.0/128,intf=01F000D0
[1382950861.443427999] TID[10260]enable participant id 449

And here no discovery between entites.
Is it because they have the same entity_id ?
They do no have the same participant id (set manually), so this one i do not know how to change it.

Regards,

Rodolf

rose's picture
Offline
Last seen: 2 years 9 months ago
Joined: 08/22/2011
Posts: 148

Hello Rodolf, 

We do not support shared memory in RTI Connext Micro – what you are enabling is the intra-Participant transport that will copy data from a DataWriter to a DataReader within a single DomainParticipant.  Since you say you have two Participant IDs, it sounds like you have two DomainParticipants, which requires that you use UDP.

Thank you!

Rose

Offline
Last seen: 9 years 11 months ago
Joined: 08/28/2013
Posts: 66

Ok thanks