RTI routing service with WAN/LAN combination

4 posts / 0 new
Last post
Offline
Last seen: 2 years 3 months ago
Joined: 07/12/2012
Posts: 51
RTI routing service with WAN/LAN combination

Is it possible to configure RTI routing service with a WAN/LAN combination ? In this scenario there is only one hardware router with a

LAN behind it. See the attached file. This is one set of settings we have tried that does not work. We have tried some others too.

The configuration is asymmetrical, so I followed as close to the asymetric one given in the RTI documentation.

If this can work, any recommendations will be appreciated.

Thanks

Nico

 

AttachmentSize
PDF icon TCP_NAT1.pdf10.49 KB
Organization:
Offline
Last seen: 3 months 3 weeks ago
Joined: 09/10/2010
Posts: 32

Hello Nico,

This is Bert.  It looks like you will need to set the public IP address in the routing service Lan 1  to the WAN IP address of the Hardware router along with its port. In your case it would be set to:  192.168.127.254:7400.  I have attached a block diagram for your reference.  Also, from the documentation, if you wanted to have Asymetric discovery, then you would not set the Initial Peers on that same Routing Service LAN1.  Let me know if these changes work for you.

Bert

Routing Service Asymmetric TCP configuration

 

File Attachments: 
Gerardo Pardo's picture
Offline
Last seen: 1 week 2 days ago
Joined: 06/02/2010
Posts: 591

Hi,

You can also take a look at this thread: http://community.rti.com/forum-topic/it-possible-rti-routing-service-raspberry-pi

The discussion and examples there seem very relevant to what you are tring to do.

Gerardo

Offline
Last seen: 2 years 3 months ago
Joined: 07/12/2012
Posts: 51

Gerardo and Bert,

The information and reference you provided, helped me to work this out.

Thanks

Nico.