Error executing CL.EXE preprocessor

2 posts / 0 new
Last post
Last seen: 2 years 10 months ago
Joined: 07/26/2021
Posts: 4
Error executing CL.EXE preprocessor

I'm getting this error message when I rund the code generator.

"INFO com.rti.ndds.nddsgen.Main Running rtiddsgen version 3.1.0, please wait ...
ERROR com.rti.ndds.nddsgen.Main Fail: java.lang.Exception: Error executing CL.EXE preprocessor

INFO com.rti.ndds.nddsgen.Main Done (failures)"


Here's a screenshot of my code generator:


I tried putting the CL.EXE file in the directory, but that didn't fix it.

I also tried to add the path to CL.EXE which didn't work as well.

Any recommendations or suggestion?

Howard's picture
Last seen: 4 days 3 hours ago
Joined: 11/29/2012
Posts: 580

On Windows, you need to have the full visual studio native tools environment set when you run the launcher if you want "rtiddsgen" to use the cl.exe preprocessor to process the idl.  But if your IDL does not have any preprocessor directives, you should just check the "Disable pre-processor" box and run.

It's much easier to run "rtiddsgen" from the command line and get it to use the using a command window that was created by the Visual Studio menu shortcut "Developer Command Prompt for VS20xx".