Problem with example hello_idl

5 posts / 0 new
Last post
Offline
Last seen: 7 years 11 months ago
Joined: 05/07/2012
Posts: 1
Problem with example hello_idl

Hello,

I have a problem running the example "C:\Program Files (x86)\RTI\ndds.4.5f\example\CPP\Hello_idl".

When I run the publisher and the subscriber on the same computer, it works correctly.

But when I run the publisher on a computer and the subscriber on another computer, it seems that enters a loop in the discovery and not send the samples correctly.


Do you have an idea what is thats the problem or any suggestion ?

Best Regards

Offline
Last seen: 4 years 7 months ago
Joined: 10/28/2010
Posts: 22

If you are using Windows OS, it seems related to the firewall, so it should be disabled to make pub/sub match each others

Offline
Last seen: 5 years 5 months ago
Joined: 06/26/2014
Posts: 4

I'm having the same problem with the Hello_idl example.

When I run the publisher and the subscriber on the same computer, it works correctly.

But when I run the publisher on a computer and the subscriber on another computer, I don't see any communication happening.  I currently have the publisher running on a Linux OS and multiple subscribers on windows and Linux machines.  Is there any configuration option I need to set on each machine? 

I currently using ndds.4.5d

Thank you

rip
rip's picture
Offline
Last seen: 3 days 12 hours ago
Joined: 04/06/2012
Posts: 321

Disable the firewalls on all machines as a test.  If connections then happen, the problem is the firewalls getting in the way.  In this case, you will need to open the DDS port ranges (there is an excel spreadsheet in the Downloads section that will compute the port ranges based on number of participants on a domain/node.

Offline
Last seen: 5 years 5 months ago
Joined: 06/26/2014
Posts: 4

Thanks for the response.  My firewalls are all turned off.  Turns out that my problem was not using the same QOS file for all apps.  Once I made sure they all used the same QOS file, everything started working

Best Regards

.