Can't set multicast TTL in QOS file

4 posts / 0 new
Last post
Offline
Last seen: 1 year 11 months ago
Joined: 07/16/2015
Posts: 17
Can't set multicast TTL in QOS file

I've tried adding the sample config from here: 

https://community.rti.com/kb/how-do-i-change-multicast-time-live-ttl

This has no effect when applied here:

 

Any ideas? I may have missed the point completely about the TTL setting example...

AttachmentSize
Image icon ttl_settings11.86 KB
Organization:
Offline
Last seen: 1 year 11 months ago
Joined: 07/16/2015
Posts: 17

...I should say that I am loading the profiles by name, and I am successfully picking up the receive address for the multicast setting in datareader_qos (I showed this for context).

There's a datawriter section (not shown) with batching options etc that also are successfully applied.

Offline
Last seen: 4 months 3 weeks ago
Joined: 02/11/2016
Posts: 142

Hey David,

Can you verify that you are creating the participant with the profile as well?

If you have trouble doing so, Admin Console should work.

Good luck,

Roy.

Offline
Last seen: 1 year 11 months ago
Joined: 07/16/2015
Posts: 17

Roy thank you.

I was creating data readers/writers with profile but not setting anything for the participant.

I created a default USER_QOS_PROFILES with the required setting and now this is at least working and I'll work out how to tidy it up later.