Connext under Ubuntu

5 posts / 0 new
Last post
Offline
Last seen: 6 years 5 months ago
Joined: 09/26/2013
Posts: 13
Connext under Ubuntu

Hi Folks,

Is Connext DDS supported under Ubuntu? if yes, how to install it?

Thanks,

Emad

Organization:
Fernando Garcia's picture
Offline
Last seen: 3 months 2 weeks ago
Joined: 05/18/2011
Posts: 198

Hi Emad,

RTI Connext DDS currently supports Ubuntu 10.04 LTS 32- and 64-bitthe next release of RTI Connext DDS will add support for Ubuntu 12.04 LTS, but I think you should be able to use the current Ubuntu bundles in your Ubuntu distribution. You can install RTI Connext DDS 5.0.0 following the RTI Core Libraries and Utilities Getting Started Guide (section 2.1.1, Installing Connext on a UNIX-based system). Note that the names of the RTI architecture for Ubuntu 10.04 are i86Linux2.6gcc4.4.3 and x64Linux2.6gcc4.4.3 for 32- and 64-bit, respectively.

You can also try the RTI Connext DDS Live CD, which is a bootable Ubuntu 12.04 32-bit distribution all the RTI software preinstalled.

Fernando.

Offline
Last seen: 6 years 5 months ago
Joined: 09/26/2013
Posts: 13

Thank you Fernando.

Actually, I want to use RTI Connext DDS along with OpenStack which is already installed on Ubuntu 12.04 LTS 64-bit. If I understood you well, there is no way to install Connext on 12.04 LTS. Is that right?

Thanks,

Emad

Fernando Garcia's picture
Offline
Last seen: 3 months 2 weeks ago
Joined: 05/18/2011
Posts: 198

Hi Emad,

Although RTI Connext DDS does not officially support Ubuntu 12.04 as for version 5.0.0, you should be able to get your applications working on Ubuntu 12.04 installing the RTI Connext DDS targets for Ubuntu 10.04 LTS (x64Linux2.6gcc4.4.3 for 64-bit) or Red Hat Enterprise Linux 6 (x64Linux2.6gcc4.4.5 for 64-bit). I have successfully run those libraries in Ubuntu 12.04 LTS in some projects.

Note that the RTI Connext DDS Live CD, which is a 32-bit Ubuntu 12.04 image, uses actually the RTI Connext Professional Edition for Red Hat Linux 6.

Fernando.

Offline
Last seen: 6 years 5 months ago
Joined: 09/26/2013
Posts: 13

Thank you very much Fernando.

I will try to install the libraries as per the installation guide and let you know.

Emad