on_data_available not getting called

3 posts / 0 new
Last post
Offline
Joined: 09/06/2018
Posts: 22
on_data_available not getting called

Hi,

We are using DDS v5.3.1 on RHEL 7.5

This problem seems to be specific to our application.  Our application has a need to publish from one module and subsribe from another module in this application.  Both the publisher and subscriber are in their own partiiapnts. We can see the DDS entities in rtiadminconsole and we can see the data flow from the publisher to the subscriber.

But, this implementation only works if our application is compiled as a single contigous application executable.

The real application has the publisher in a plugin module, which is a shared library.  The subscirber resides in the framework application which loads the plugin.

Any ideas as to why this does not work?  Does the shared library have to be built in a certain way?  

 

tia,b

 

 

sara's picture
Offline
Joined: 01/16/2013
Posts: 119

Hi,

Creating a modular application as you are trying to do is the regular way of doing things with Connext, it's what we do in some of our tools.

Have you tried following this article  for debugging? Which was the result?

All the best,
Sara

Offline
Joined: 09/06/2018
Posts: 22

The issue has been resolved.  The problem was that we were using RTI DDS as a shared library for our plugins but the main application was using the RTI DDS library as static.  We had to use the shared library setup for our plugins and main application