QoS partitions for recording service

1 post / 0 new
Offline
Last seen: 2 months 2 weeks ago
Joined: 06/03/2020
Posts: 1
QoS partitions for recording service

I am trying to configure the recording service to record partitions. I am using the template recording config with 2 changes

```

<!-- Qos Library -->
<qos_library name="QosLibrary">
<qos_profile base_name="TeleroboticsQos::RealTime" name="RealTimePartition" >
<subscriber_qos>
<partition>
<name>
<element>*</element>
<element>"*"</element>
<element>rover</element>
<element>"rover"</element>
</name>
</partition>
</subscriber_qos>
</qos_profile>
<qos_profile base_name="TeleroboticsQos::RealTime_Exclusive" name="RealTime_ExclusivePartition" >
<subscriber_qos>
<partition>
<name>
<element>*</element>
<element>"*"</element>
<element>rover</element>
<element>"rover"</element>
</name>
</partition>
</subscriber_qos>
</qos_profile>
</qos_library>

```

Here I am defining 2 QoS profiles that are based on profiles referenced from $NDDS_QOS_PROFILES. I want to use the same QoS settings, but I want to add a partition that the recording service will listen to

 

```

<!-- Top-level session settings -->
<session name="DefaultSession" default_participant_ref="RecordingService">
<topic_group name="NonExclusiveTopicGroup">
<!-- Topics to record -->
<allow_topic_name_filter>Ambot*</allow_topic_name_filter>
<deny_topic_name_filter>rti/*</deny_topic_name_filter>
<datareader_qos base_name="QosLibrary::RealTimePartition"/>
</topic_group>
<topic_group name="ExclusiveTopicGroup">
<!-- Topics to record -->
<allow_topic_name_filter>QDot*</allow_topic_name_filter>
<deny_topic_name_filter>rti/*</deny_topic_name_filter>
<datareader_qos base_name="QosLibrary::RealTime_ExclusivePartition"/>
</topic_group>
</session>

```

Here I am defining 2 topic groups with topics that I want to record. 

I want to record the communication between 3 c++ programs that all use the QoS from  $NDDS_QOS_PROFILES (some on exclusive, some on non-exclusive topics) and a partition called "rover". When I record and the c++ programs use the default ("") partition, everything works fine, but when I use the "rover" partition, nothing is recorded and the admin console claims that there are "no matching partitions". 

 

Can anyone show me where I'm going wrong here please?

 

Kind regards,

 

Lukas