rtirecord hangs when recording ping at 100 samples per second

4 posts / 0 new
Last post
Offline
Last seen: 4 years 4 months ago
Joined: 02/26/2016
Posts: 5
rtirecord hangs when recording ping at 100 samples per second

I'm remotely controlling rtirecord using a java application. It works fine recording pings until I increase the sample rate to 100 samples per second. At different points in my application, the rtirecord process stops sending heart beat and stalls. Attached is the java code and rtirecord xml file I use.

AttachmentSize
File rtirecord.xml4.25 KB
File rtirecordcontrolsample.java9.64 KB
Organization:
Offline
Last seen: 1 month 5 days ago
Joined: 01/15/2013
Posts: 94

Hi Paul,

Does the Recorder application crash or just stops sending status messages through administration?

Did you check the integrity of the recorded data? Is Recorder losing samples? Are any sample-lost messages printed out?

Thanks,

Juanlu

Offline
Last seen: 4 years 4 months ago
Joined: 02/26/2016
Posts: 5

The process doesn't die, but the data file doesn't seem to grow once it stalls. I'm not watching stdout from the rtirecord process, but I could do that.


UPDATE: It gets more interesting ... It seems to be environment / network related.  The problem was pretty reliable in occurance, although sometimes would happen when I send resume, and other times when i send stop. However, this only happens on my home network. The same VM running on the same laptop connected at my office LAN does NOT have this problem at all!!!

Offline
Last seen: 1 month 5 days ago
Joined: 01/15/2013
Posts: 94

That's indeed strange, so this could be related to the DDS layer.

Are you just publishing the PingTopic? Is Recorder's memory growing?