Subscriber not getting messages from Publisher

7 posts / 0 new
Last post
Offline
Joined: 06/26/2014
Posts: 4
Subscriber not getting messages from Publisher

I'm new to RTI DDS and I'm trying to figure out why my DDS  subscriber is not getting messages from my publisher.  I'm running both application on my local computer (Redhat 5 Linux).  My firewalls and iptables are turned off and I'm using the same QOS file for both applications.  Using rtid dds 4.5d

Using the RTI Analyzer I can see that  the Match Analysis was successful (all green).

I used rtiddsspy and can see the messages being sent using the correct topic and type

I also used rtiddsping as a publisher and subscriber of my messages types.  Using rtiddsping as a publisher, I can see my subscriber recieving messages.  Using rtiddsping as a subscriber, I see it getting messages from my publisher.

Not sure why its not working.  Any other suggestion?

gianpiero's picture
Offline
Joined: 06/02/2010
Posts: 171

Hello, 

you did already what i was going to suggest... so AppSub and AppPub are on the same machine and if you run AppPub and spy you can see the messages ... also ping and spy works fine.. 

so it looks that the AppPub is working fine.. so maybe the problem is in the AppSub. Analyzer shows matching happening.. so maybe your subscriber is not subscribing to the on_data_available correctly? 

Also try to turn on verbosity:

<participant_factory_qos>      
   <logging>      
    <category>API</category>      
    <verbosity>ALL</verbosity>
  </logging>    
</participant_factory_qos>

Let me know!
  Gianpiero

gianpiero's picture
Offline
Joined: 06/02/2010
Posts: 171

Hello,

Also, have a look to this answer http://community.rti.com/comment/1995#comment-1995 and see if that helps!

Best,
  Gianpiero

Offline
Joined: 06/26/2014
Posts: 4

Thanks for the suggestions. Turns out that I was not using the same QOS file after all. I was launching the applications using two different user accounts. One account had a QOS in the home directory (Not the working directory). Once I removed that it started working. I did try a bunch of other stuff also, one was to edit the NDDS_DISCOVERY_PEERS environment variable to include shmem:// Thanks again.

gianpiero's picture
Offline
Joined: 06/02/2010
Posts: 171

You are welcome! Glad you find the issue! 

Best,
  Gianpiero

Offline
Joined: 11/09/2018
Posts: 2

Hello,
For my license provided by rti dds analyzer is not working y is it so.

sara's picture
Offline
Joined: 01/16/2013
Posts: 119

Hi,

Which version of Connext are you using? RTI DDS Analyzer was deprecated a while ago and now Admin Console is the one you should use. Is that one workign for you?

Thanks,
Sara