Using RTI DDS 4.2e with Visual Studio 2015

4 posts / 0 new
Last post
Offline
Joined: 06/24/2016
Posts: 7
Using RTI DDS 4.2e with Visual Studio 2015

I am attempting to use RTI DDS 4.2e using Visual Studio 2015 as a development environment.

I have encountered the problem described in the following: https://community.rti.com/kb/can-i-use-visual-studio-express-build-rti-connext-applications Part 4: ‘_TP_CALLBACK_ENVIRON::::’

I can't install the 2005 SDK in VS2015, therefore this solution is not available. Reading the article it suggests that the ‘Private’ macro should have the value removed, as for the previous ‘Public’, ‘Package’ and ‘Peer’ entries. However when I do this I get a different error in a different windows header on a different ‘Private’ attribute. Instead I have changed ‘log_makeheader.h’ to #define Private_Test static

Using this the HelloWorld example compiles, and I am able to send and receive messages. Looking at the use of ‘Private’, I assume we can ignore all entries in file ‘dds_c_data_TDataReader.gen’ as I am using C++, not C. Looking through the rest of the code I do not see anywhere else that would impact us – however is there anything else I need to be aware of if I continue?

Keywords:
jwillemsen's picture
Offline
Joined: 09/24/2013
Posts: 53

This sounds tricky, using a version of RTI DDS for Visual Studio 2005 and use it with 2015. We had various problems when we tried to use a Visual Studio 2013 RTI DDS version with Visual Studio 2015. RTI DDS 5.2.3 does have formal support for Visual Studio 2015, we use it and it works perfect.

Offline
Joined: 06/24/2016
Posts: 7

Hello,

Thank you for your reply. Unfortunately we are constrained by the other platforms we use, and DDS 4.2e is the latest version which is supported on everything. Therefore moving to a later DDS would be a major undertaking.

jwillemsen's picture
Offline
Joined: 09/24/2013
Posts: 53

It sounds to me safer to use Visual Studio 2005 as IDE when Microsoft doesn't support the 2005 SDK in their recent 2015 IDE.