Virtual Machine in VMWare using DDS

3 posts / 0 new
Last post
Offline
Last seen: 1 week 6 days ago
Joined: 05/09/2019
Posts: 7
Virtual Machine in VMWare using DDS

I have one virual machine that created by VMWare 15 pro. I installed Ubuntu 18.x and RTI DDS 6.0.0. My VM network adapter setting is 'Bridged (Connected directly to the physical network). So my VM can get IP from DHCP server in my local area network. Now my question is my VM can not communicate with other machine that is real machine (ex: another windows machine that installed RTI DDS 6.0.0).

One real machine: Windows 10/RTI DDS 6.0.0/rtishapedemo publish some Shapes/IP is 192.168.10.50

My VM : Ubuntu 18.x (Even Windows Platform is same)/RTI DDS 6.0.0/rtishapedemo subscribe Shapes/IP is 192.168.10.99

By the way. Two machine can ping each other anytime. rtiadminconsole program can not find each other also.

-- Arthur.

Offline
Last seen: 6 days 19 hours ago
Joined: 09/23/2018
Posts: 8

It might be a firewall issue.  Temporarily disable it on both to see if it makes a difference.   

You may also want to use the <allow_interfaces_list> construct to limit communications to specific interface(s): https://community.rti.com/kb/how-do-i-restrict-rti-connext-use-only-subset-interfaces

VirtualBox and Vmware install a number of virtual networks and that often causes configuration problems.

RTI DDS Ping is a good place to start with problems like this,  it has a number of profiles that allow you to limit transports, etc.

Offline
Last seen: 1 week 6 days ago
Joined: 05/09/2019
Posts: 7

Hi garyb,

Thank you for your reply.

It is not firewall issue. Virtual machine (ubuntu) didn't turn on the firewall and host machine (Windows) already turn off firewall.

DDS just can communicate with other real machine by using NDDS_DISCOVERY_PEERS environment variable. My question is machines (no mater what is VM or real machine) located in the same subnet. Their IP is 192.168.10.x. Why the VM need to set NDDS_DISCOVERY_PEERS to discovery same subnet host?

By the way. I set allow_interfaces_list in my Qos XML profile. It still didn't work.