Why do I get an UnsatisfiedLinkError or Flexlmclient error when running RTI Analyzer on a Windows system?

Note: Applies to RTI Data Distribution Service 4.2e.

An UnsatisfiedLinkError message or a message stating "Failed to load Flexlmclient library" indicates that Microsoft┬« Visual C++ 2005 Service Pack 1 is not installed.

RTI Analyzer is part of RTI Developer Platform. RTI Developer Platform 1.2 and higher requires the DLLs bundled in Visual C++ 2005 Service Pack 1.

If you do not have Visual C++ 2005 Service Pack 1 installed, download and install the Microsoft Visual C++ 2005 SP1 Redistribution Package (x86) from RTI's Self-Service Portal. The file, vcredist_x86.exe, is listed in the Downloads section under Windows Target Libraries for RTI Data Distribution Service 4.2e

You can also download the package from Microsoft's website: http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-389C36F85647&displaylang=en.

Product:
Platform: