Routing Service adapter on a Rasberry Pi

4 posts / 0 new
Last post
Offline
Last seen: 5 years 3 months ago
Joined: 06/07/2016
Posts: 2
Routing Service adapter on a Rasberry Pi

Hi,

I am trying to run a Routing Service adapter on a Raspberry Pi. I have read on the Routing service's release notes that Raspbian Wheezy 7.0 is supported. However, I can't find the resources to do that, when I try to download DDS connext there is not a version for ARM, and using the target libraries for Raspbery Pi as indicated on the tutorial https://community.rti.com/howto/run-rti-connext-dds-raspberry-pi, the library -lrtirsinfrastructure, or the needed libraries to link the Routing Service as a library to the app are not included. Then, how can the Routing Service be used on a Raspberry Pi?

 

Thanks,

Pilar

Gerardo Pardo's picture
Offline
Last seen: 1 month 4 days ago
Joined: 06/02/2010
Posts: 598

Hello Pilar,

What version of Connext DDS are you using? You can download the Raspberry Pi libraries from here: https://community.rti.com/downloads/rti-connext-dds-raspberry-pi

Gerardo

 

Offline
Last seen: 5 years 3 months ago
Joined: 06/07/2016
Posts: 2

Hi Gerardo,

I'm using the 5.2.0 version, I reinstalled the Raspberry Pi libraries for this version and I can cross compile my routing service adapter, but, since I want to run Routing Service on the Raspberry Pi which doesn't have RTI Connext installed, I want to link Routing Service as a library in my app. However, when I try to cross compile the example given (routing_service_lib), I get an error because the libraries -lrtiroutingservicez and -lrticonnextmsgcz cannot be found.

 

Thanks,

Pilar

Fernando Garcia's picture
Offline
Last seen: 1 month 6 days ago
Joined: 05/18/2011
Posts: 200

Hi Pilar,

Are you using the rti_connext_dds-5.2.0-core-target-armv6vfphLinux3.xgcc4.7.2.rtipkg or the rti_connext_dds-5.2.0-pro-target-armv6vfphLinux3.xgcc4.7.2.rtipkg target bundle? If you are using the former, it does not contain the libraries that you need to build Routing Service into your application (i.e., librtiroutingservicez and librticonnextmsgcz). If that is the case, please check whether you have access to the pro target bundle on https://support.rti.com. If you do not, please let me know and I will check with the accounting team what you have access to.

Thanks,
Fernando.