Shapes Demo not working on Ubuntu 16.04

2 posts / 0 new
Last post
Last seen: 6 years 1 month ago
Joined: 04/12/2018
Posts: 1
Shapes Demo not working on Ubuntu 16.04

I have two Ubuntu 16.04 machines on a local network (hard wired to a router thats doing DHCP) running Connext Pro 5.3.0.  I simply installed pro, ran the launcher, and tried the shapes demo, publishing from one machine and subscribing from the other.  I can not see any data from the topic i'm subscribing to.  Tried this in both directions.

I can ping both ways without issue.  Running the admin console, I can see the domain participant running on the other machine, but can not see the datawriter or datareader from the other machine.  It looks like there's no firewall running on either machine.  I can get this to work using two windows machines through the same router.

Confused, not sure what the problem is but seems to be specific to ubuntu.

pranjali's picture
Last seen: 5 years 10 months ago
Joined: 01/16/2018
Posts: 4


You mention you got the ping work both ways without issue. Was this the ICMP ping or rtiddsping? 

As both the machines are hard-wired to a router, they have to be in different subnets. Did you try setting the initial_peers in the QoS profile? 

Also, in the admin console do you see any QoS mismatch?