Connext DDS Professional 5.3

2 posts / 0 new
Last post
Offline
Last seen: 4 years 5 months ago
Joined: 04/12/2018
Posts: 1
Shapes Demo not working on Ubuntu 16.04

I have two Ubuntu 16.04 machines on a local network (hard wired to a router thats doing DHCP) running Connext Pro 5.3.0.  I simply installed pro, ran the launcher, and tried the shapes demo, publishing from one machine and subscribing from the other.  I can not see any data from the topic i'm subscribing to.  Tried this in both directions.

3 posts / 0 new
Last post
Offline
Last seen: 3 years 3 months ago
Joined: 03/02/2018
Posts: 3
DDS makes Intellisense stop working in Visual Studio 2015

Background:

RTI 5.3.0, Professional

 

Basic IDL, 

struct Encoder {

unsigned long relativePosition;

unsigned long absolutePosition;

};

 Run it through rtiddsgen; pretty much all defaults except preprocessor disable.

C:\Program Files\rti_connext_dds-5.3.0\bin\rtiddsgen.bat C:\__\dds_intellisense_problem\Encoder.idl -ppDisable -language C++11 -create typefiles -create examplefiles -create makefiles -platform i86Win32VS2015 -stl

Subscribe to RSS - Connext DDS Professional 5.3