rtiddsgen

rtiddsgen: Command not found

Hello

I'm a teaching assistant for "Distributed system concepts and programming" and we have a project to create a simple publisher/subscriber using RTI Connext DDS.

Now, few students have the problem to use "code generator" in RTI launcher and got the error indicating "rtiddsgen: Command not found", although they set the path and environmentariables correctly.

I attached screenshots of the bash and SSH terminal.

Can somebody help, please?

Keywords:

create typecode from xml error processing tag "include"

I am trying to use the .NET create_tc_from_xml_file class to generate type codes from XML and I receive the following error in the console: 

RTIXMLParser_onStartTag:Parse error at line 3: Error processing tag 'include'
RTIXMLParser_parseFromFile:Parse error in file 'C:\XMLDataStruct\thisModule.xml'
DDS_XMLTypeCodeParser_parse_from_file:Error parsing XML
DDS_TypeCodeFactory_create_tc_from_xml_file:!error parsing types file

The XML files were generated from IDL using rtiddsgen, and the includes are at the top of the XML:

Updating from 5.1.0 to 5.3.1

Hello,

I'm trying to get this package compiled on my machine https://github.com/hengli/vmav-ros-pkg which states this requirement "RTI Connext DDS >= 5.1.0 (Source install to /opt)". I've managed to get RTI installed on my computer but then I ran into this bug https://github.com/hengli/vmav-ros-pkg/issues/4

Keywords:

rtiddsgen manual?

Hi,

 

Is there a manual that goes into detail about rtiddsgen in v5.3.1?  T

he -help is very long but I stil need more info.  For example, does rtiddsgen always generate a pubshlier and subsriber in seperate files?  Is it possible to direct rtiddsgen to put the publisher and subscriber into a single file, like some of the examples that ship with RTI DDS v5.3.1?

 

tia,bernie

 

Keywords:

DDS makes Intellisense stop working in Visual Studio 2015

Background:

RTI 5.3.0, Professional

 

Basic IDL, 

struct Encoder {

unsigned long relativePosition;

unsigned long absolutePosition;

};

 Run it through rtiddsgen; pretty much all defaults except preprocessor disable.

C:\Program Files\rti_connext_dds-5.3.0\bin\rtiddsgen.bat C:\__\dds_intellisense_problem\Encoder.idl -ppDisable -language C++11 -create typefiles -create examplefiles -create makefiles -platform i86Win32VS2015 -stl

rtiddsgen Bitfield Question

Hi,

I'm new to DDS and I was looking through the rtiddsgen release notes and found that bitfields are no longer supported.

I have several messages I'm interested in creating IDL files for that have a format similar to:

rtiddsgen utility

Can Anyone please tell how I can I set the environment variables for rtiddsgen utility. I have read the documentation and tried every possible thing but still unable to run rtiddsgen to generate code from idl file. If possible please specify step by step solution with example. Thanks in advance for the help. I am using Windows 7, 64 bit platform.

Organization:
Keywords:

rtiddsgen issue with handling identical files in separate directories


The other day a colleague of mine stumbled upon an issue (a bug perhaps) with the include guards in a C++ header file generated using the rtiddsgen tool. I have verified that the behavior is the same with the following versions of rtiddsgen: 5.0.0, 5.1.0 and 2.2.0.0 (rtiddsgen2).

We have two files with the same name, in different directories, whose contens are identical with the exception of the module declarations. Running rtiddsgen on these files produces identical include guards, which is quite problematic for obvious reasons.

Keywords:

rtiddsgen 5.1.0 generating C++ code that will not link

We are currently trying to migrate from RTI DDS 5.0.0 to 5.1.0, and have observed some strange behavior in the C++ code that is generated by the rtiddsgen tool. The issue we are seeing is when we have an idl file that contains only a single enum definition, and it is included and used by another idl file. It appears as though there is a function, MyEnum_finalize_optional_members(...), which is declared but not defined in the generated code.

As an example, In our enum.idl file, we have the following:

enum MyEnum { ENUM_1 = 0, ENUM_2 = 1, ENUM_3 = 2, NUM_MY_ENUMS };

Keywords:

Compiler problems in generated C++ code

Hello all,

I've run into a number of problems when compiling the C++ code generated from my IDLs in Visual Studio 2013.  I've fixed them manually but I'd like to ask whether it's the "right" fix.  Also consider this a bug report, I suppose :)

Facets of my environment:
1. The code is generated from a hierarchy of IDL files with lots of #includes, inheritance, and composition using included types as fields.
2. I'm using the IDLs of a project in-progress, so I can submit some changes back to them but only if necessary.

Pages

Subscribe to RSS - rtiddsgen