Admin Console Tool not working

11 posts / 0 new
Last post
Offline
Last seen: 1 year 9 months ago
Joined: 03/27/2013
Posts: 28
Admin Console Tool not working
AttachmentSize
Plain text icon log.txt282.86 KB

Hello

I'm testing the connection between an application in C# and the other one in LabVIEW.
The subscriber does not receive the data and vice versa. It seems like there is an issue with my topic definition in these apps. Therefore, I need to check what these apps are doing exactly.
I tried to run the Admin Console tool (and also the Monitor tool), but it does not start at all. I checked the log file and the errors are caused by java exceptions. I will attach the log file here. I used the ddsspy tool which still works, but it does not help me with this problem. 

I'm using RTI Connext 5.2.3 on a 64x Windows 10 PC and the java is updated, by the way.

Is there any way to fix this problem?

Thanks in advance

 

Offline
Last seen: 2 months 5 days ago
Joined: 02/11/2016
Posts: 142

Hello,

 

First of all I would dare say java 1.7 is not an updated version when java 1.8 has been with us over 3 years now.

But I also think 1.7 should work.

I am suspecting one of two likely issues, both related to environment variables:

1. have you set NDDSHOME to point to your rti installation?

2. have you added the path of the relevant build to your PATH?

I think one of these was not handled (most likely the latter but possibly also the first?)

Hopefully this sorts out your issues.

 

Good luck,

Roy.

 

Offline
Last seen: 1 year 9 months ago
Joined: 03/27/2013
Posts: 28

Hi Roy,

Thanks for your reply, but both of the environment variables are set.

I have the latest Java 1.8 installed but the Admin Console still uses the 1.7 version as you had seen in the log file. Could it be the problem? Any idea what else could be the cause?

Offline
Last seen: 2 months 5 days ago
Joined: 02/11/2016
Posts: 142

If you can, please post your exact PATH/NDDSHOME environment variables.

Offline
Last seen: 1 year 9 months ago
Joined: 03/27/2013
Posts: 28

Sure.

NDDSHOME: C:\Program Files\rti_connext_dds-5.2.3

PATH:C:\Users\...\AppData\Roaming\npm;%USERPROFILE%\AppData\Local\Microsoft\WindowsApps;

PATH (append): C:\Program Files\rti_connext_dds-5.2.3\lib\x64Win64VS2015; C:\Program Files\rti_connext_dds-5.2.3\lib\java;

Offline
Last seen: 2 months 5 days ago
Joined: 02/11/2016
Posts: 142

Hey,

What is your JAVA_HOME?

Roy.

Offline
Last seen: 1 year 9 months ago
Joined: 03/27/2013
Posts: 28

JAVA_HOME: C:\Program Files\Java\jre1.8.0_131

Update:
I had not added the JAVA_HOME to the PATH variable
PATH: C:\Users\...\AppData\Roaming\npm;%USERPROFILE%\AppData\Local\Microsoft\WindowsApps; %JAVA_HOME%\bin

But the tool still does not execute after the update.

 

Fernando Garcia's picture
Offline
Last seen: 2 hours 15 min ago
Joined: 05/18/2011
Posts: 196

Hi Randy,

The scripts that launch Admin Console use a JRE that is shipped along with RTI Connext DDS, which is known to work with Admin Console.

The issue in your case seems to be related to the presence of nddsjava.dll in your path. more specifically in C:\Windows\System32\nddsjava.dll. The version of nddsjava.dll there might be different to the version that Admin Console is expecting to load. Could you move all the DDS libraries you have under C:\Windows\System32 momentarily and try to re-launch Admin Console? Please make sure that no other RTI libraries are in the Path at the moment that you launch the application.

Thanks,
Fernando.

Offline
Last seen: 1 year 9 months ago
Joined: 03/27/2013
Posts: 28

Hi Fernando,

Thanks a million, that solved the problem. Shall I remove all those libraries from the Path permanently?

Fernando Garcia's picture
Offline
Last seen: 2 hours 15 min ago
Joined: 05/18/2011
Posts: 196

Hi RJ,

I am glad we go that to work. 

Unless you need those libraries under C:\Windows\System32 for a particular reason, you can go ahead and remove them permanently. They could cause conflicts with other applications.

Thanks,
Fernando.

Offline
Last seen: 1 year 9 months ago
Joined: 03/27/2013
Posts: 28

Ok Fernando. Thank you again for your great support.

Randy