can't get routing service to work with own app but only with ShapeDemo

3 posts / 0 new
Last post
Offline
Last seen: 1 year 7 months ago
Joined: 09/24/2017
Posts: 4
can't get routing service to work with own app but only with ShapeDemo

I have problem using routingservice to get applications talk to each other

The scenario is as follow:
I have a two computers on the same lan, one debian8 linux and one windows7.
And a docker container is running inside linux.
Windows has no route to docker inside linux,
but I thougth that this can be solved by using routingservice running on the windos and linux host.
And it works fine for ShapeDemo but not for my own Application?
I am using example 8 in Routing_service users guide,
with tcp_transport.xml but have same domain id for both participants.
I also set NDDS_DISCOVERY_PEERS on windows and linux to point to each other, as described in the example.
And NDDS_QOS_PROFILES are in both cases set to point to our own internal qos-settings.

I don't understand why ShapeDemo works fine but not my own application,
my own application works fine if both parts run inside docker.
and I know routing service is configured correct because ShapeDemo works.
Any idea how to proceed with the the troubleshooting is welcome

I haven't been able to do rtiddsping between docker and windows either, dont know how to do that...
Windows: "%NDDSHOME%\bin\rtiddsping" -peer tcvp4_wan://<linuxIP>
docker: $NDDSHOME/bin -subscribe -peer tcpv4_wan://<windowsIP>

I have DDS version 5.2.0 on windows and DDS version 5.2.3 on linux and in docker.

 

ajimenez's picture
Offline
Last seen: 1 year 1 month ago
Joined: 09/29/2017
Posts: 21

Hi Lars,

It seems to be a problem of initial peers.
Are you setting NDDS_DISCOVERY_PEERS as an environment variable?
Could you please upload the XML configurations of the both RTI Routing Service and your application?
Could you check also if RTI shape demo is working without using RTI Routing Service?

Thank you.
Antonio

Offline
Last seen: 1 year 7 months ago
Joined: 09/24/2017
Posts: 4

Hi Antonio

I have solved this. The routing service was overkill. It is intended for cases when applications are separated by a wide area network.

In my case the solution was much simpler because everything is on the same LAN.
All I had to do was to ensure that the --net=host switch was given in the docker run command.