Changing RTI Routing Service Presentation QOS [Solved]

3 posts / 0 new
Last post
Offline
Last seen: 6 years 7 months ago
Joined: 11/16/2015
Posts: 7
Changing RTI Routing Service Presentation QOS [Solved]

Hi all,

I have a Routing Service set up to relay data received on domain 1 (asymmetric TCP) to domain 0 (shmem) and a remote application that pumps data into domain 1 so that a client application of mine can consume it in domain 0.

However, when I start up the system, the RTI admin console presents me with the following problem:

It seems that the Routing Service and my client application do not agree on the data presentation, and thus no samples are delivered.

I'd prefer to solve this problem by having the Routing Service deliver samples in TOPIC_PRESENTATION_QOS, in-order (in other words, change the Routing Service Presentation QoS to match that of my client application).  But, as far as I've been able to discern, the only valid place for the <presentation> tag is in the hierarchy <qos_library> -> <qos_profile> -> <subscriber_qos>, which does not exist in the Routing Service's XML files.  So, my main question is, how can I create a QoS profile that the Routing Service will use for this domain?

 

Hope you can help.

 

Thanks

/Franck

Organization:
Fernando Garcia's picture
Offline
Last seen: 6 months 2 weeks ago
Joined: 05/18/2011
Posts: 200

Hi Franck,

You can modify your Publisher's Qos at the session level. Here is how:

<routing_service name="example">
    ...
    <domain_route name="DomainRoute"enabled="true">
        ...
        <session name="Session" enabled="true">
            <publisher_qos>
                <presentation>
                    <access_scope>INSTANCE_PRESENTATION_QOS</access_scope>
               </presentation>
            </publisher_qos>
            ...
            <topic_route name="SquaresToCircles>
            ...
         </session>
    </domain_route>
</routing_service>

Note also that Routing Service's configuration file allows also the declaration of Types, QosLibraries, QosProfiles, etc. under the root tag <dds> at the same level as your <routing_service> configuration.

Thanks,
Fernando.

Offline
Last seen: 6 years 7 months ago
Joined: 11/16/2015
Posts: 7

Thanks, Fernando.  That was exactly what I needed - problem solved :)