Error running the performance latency test

2 posts / 0 new
Last post
Offline
Last seen: 5 years 9 months ago
Joined: 09/21/2013
Posts: 3
Error running the performance latency test

I am trying to gather a benchmark of throughput and latency performance using RTI Connext running in different geographic regions. When I run the latency test ($NDDSHOME/examples/JAVA/performance/latency/) with 1 Publisher and 1 Subscriber, the test completes successfully. 

As soon as I use 2 or more Subscribers, there is no result and I keep seeing this error:

Did not get reply at sn 1

I have even tried recompiling the code to change the time out from 1 second to 10 seconds, to no avail. 

 

When I turn on reliability mode, I see this error

Incompatible QoS Reliability

Note that I have tested 1 Pub: 1 Sub successfully across geographic regions. There should not be any network or configuration issues. Is there any tweaking that I can do to ensure the latency test can run well?

 

 

Organization:
Offline
Last seen: 5 months 1 week ago
Joined: 05/23/2013
Posts: 49

Hi hanxue,

Did you set the "sidMultiSubTest" and "numSubscribers" parameters for multiple subscribers?

When you turn on reliability mode, did you change the value of the "bestEffort" parameter or did you change the QoS XML file?

Kyoungho