Trouble installing onto a cRio

8 posts / 0 new
Last post
Offline
Last seen: 7 months 4 weeks ago
Joined: 03/12/2021
Posts: 10
Trouble installing onto a cRio

So I'm hoping I can use rti dds on a project for communicating between some cRio-9041s that I have.

I installed things on my development computer without issue, now I need to install things on the cRios.  I'm going through the instructions in the document at:

https://community.rti.com/static/documentation/connext-dds/5.2.3/doc/manuals/labview/RTI_DDS_Toolkit_for_LabVIEW_GettingStarted.pdf

but when I get to step 10 in section 1.2.1, I don't see the RTI DDS Toolkit for LabVIEW in the list of components available to install

Am I missing something?  Not sure what to try next.  Any help would be appreciated

J

Ismael Mendez's picture
Offline
Last seen: 1 week 4 days ago
Joined: 07/03/2017
Posts: 36

Hi jwebster8,

You should be able to see it in MAX since the cRIO 9041 uses an Intel 64 CPU and NI Linux 64bit. What versions of LabVIEW, LabVIEW Real Time, and the DDS Toolkit are you using?

You can try to install it manually. But keep in mind that in case you want to remove it you'll have to delete the files manually. To do it, do the following:

Extract the content of the file "data.tar.gz" included in the compressed file "<National Instruments installation folder>\RT Images\RTI DDS Toolkit\3.0.0\x64intel\rti_dds.tar" in your cRIO's root folder. So you'll have, for example, the content of the /usr/local/rti/lib in the compressed file into /usr/local/rti/lib in your CRIO. The same for the folders home and etc in the compressed file. After that restart the cRIO.

Regards

Ismael

Offline
Last seen: 7 months 4 weeks ago
Joined: 03/12/2021
Posts: 10

Labview 2019 sp1

Labview Real-Time 19.5.1

RTI Labview DDS 1.3.2.93

RTI DDS Toolkit for Labview (RT-support) 1.4.0.94

I'd rather not install manually if I can avoid it.  I have multiple systems and I'd like to keep things as simple as possible

 

 

Ismael Mendez's picture
Offline
Last seen: 1 week 4 days ago
Joined: 07/03/2017
Posts: 36

Can you try a newer version of the DDS Toolkit and see if you still have the same issue? The latest one is 3.0.0.109.

Offline
Last seen: 7 months 4 weeks ago
Joined: 03/12/2021
Posts: 10

Hmm, a search on VIPM only gives me 1.4  https://www.vipm.io/search/?q=rti+dds 

I'm surprised its that far behind.  Do you have a download link?  I'm still learning my way around

 

Ismael Mendez's picture
Offline
Last seen: 1 week 4 days ago
Joined: 07/03/2017
Posts: 36

Maybe you have to update VIPM to a newer version. In this link you can version 3.0.

https://www.vipm.io/package/real-time_innovations_lvdds/

Offline
Last seen: 7 months 4 weeks ago
Joined: 03/12/2021
Posts: 10

 

After installing version 3.0.0.109 of the toolkit, and 1.3.2.93 of the Toolkit for LabVIEW, when I try to install the Toolkit for LabVIEW (RT-support) using VIPM, I get a popup that says "None of the packages found can be installed in your currently displayed LabVIEW version because they are not compatible"


Offline
Last seen: 7 months 4 weeks ago
Joined: 03/12/2021
Posts: 10

I think I might have figured it out.  I was installing "RTI DDS Toolkit" AND "RTI DDS Toolkit for Labview", and then trying to install RTI DDS Toolkit for RT Targets" and the last two are redundant.  If you install RTI DDS Toolkit ver 3 you get the labview toolkit, and the toolkit for RT targets.

Makes sense now, but it's not obvious when first viewing the VIPM packages