Can not connect to RTI support page

7 posts / 0 new
Last post
Offline
Last seen: 1 year 9 months ago
Joined: 08/11/2019
Posts: 28
Can not connect to RTI support page

Hello,

When I try to login https://www.rti.com/support, it can not pass.

I also delete cookie but it still can not log in.

After I type my account, the page will reflash to the same page.https://www.rti.com/support?error=login

And I try forgot password, it didn't send e-mail.

AttachmentSize
Image icon ddsq.jpg116.16 KB
r
Offline
Last seen: 1 month 1 week ago
Joined: 06/17/2019
Posts: 33

I believe www.rti.com/support requires third party cookies to be enabled. Newer versions of some browsers have disabled third party cookie support by default (I had similar issues on firefox and chrome).

I recommend you try using microsoft edge or enabling third party cookies on your current browser.

But this shouldn't affect your ability to receive a password reset. If you've already checked your spam folder, there may be a different issue causing that.

Offline
Last seen: 1 year 9 months ago
Joined: 08/11/2019
Posts: 28

Hello, r

Thank you for your suggestion, but I already tried using microsoft edge and enabling third-party cookies on chrome, it still can not work.

You mean you can log in now? if so means that is my setup problem instead website or GW issue. 

r
Offline
Last seen: 1 month 1 week ago
Joined: 06/17/2019
Posts: 33

Yes I am able to login now and receive password resets. The password reset email came through in less than 30 seconds. 

To login I used Microsoft Edge 44.17763.1.0
Microsoft EdgeHTML 18.17763

I don't think I have any special configuration for MS edge

Fernando Garcia's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: 05/18/2011
Posts: 200

I have had similar problems with Firefox. The support team posted a knowledge base article about it recently:

https://community.rti.com/kb/why-cant-i-login-rtis-self-service-portal-my-browser

Let me know if this helps,
Fernando.

Offline
Last seen: 1 month 2 weeks ago
Joined: 12/07/2021
Posts: 4

I just created a community account,but I can not log in https://support.rti.com/s/login/.And I can not receive a  get name email. So I don't have one account on that.But I can't find a link to create a account too.

r
Offline
Last seen: 1 month 1 week ago
Joined: 06/17/2019
Posts: 33

Hi Fullline, 

Accounts on our community site (to post on the forums here) and accounts on our support site are different. I believe only commercial and IRAD customers have access to our support site. If you are on a 30 day trial ,I don't believe you will have access to our support site.

If you don't have access to our support site and you think you should, you can reach out to your local account manager or FAE (see the bottom of this page: https://www.rti.com/company/contact)