How to enable reserve participant index?

3 posts / 0 new
Last post
Offline
Last seen: 6 years 9 months ago
Joined: 10/10/2012
Posts: 24
How to enable reserve participant index?

Currently I am testing latency performance with the example code from the RTI suite. In my setup I need to run several participants on one host (one participant for Latency, two participants on my Gateway). When the gateway is running and I try to start the Latency test, I get an error when trying to enable the participant for LatencyPublisher (sourcecode not changed):

Exception in thread "main" com.rti.dds.infrastructure.RETCODE_ERROR
    at com.rti.dds.util.Utilities.rethrow(Unknown Source)
    at com.rti.dds.infrastructure.RETCODE_ERROR.check_return_codeI(Unknown Source)
    at com.rti.dds.infrastructure.EntityImpl.enable(Unknown Source)
    at latency.LatencyPublisher.publisher_main(LatencyPublisher.java:165)
    at latency.LatencyPublisher.main(LatencyPublisher.java:42)
[D0000|ENABLE]DDS_DomainParticipantPresentation_reserve_participant_indexI:!enable reserve participant index

How do I enable the reserve participant index? Or do I have to solve the problem by increasing the max participant index? For the tests LatencyPublisher is using UDPv4. If I try to use shared memory (otherwise same scenario), I get the following error:

Exception in thread "main" com.rti.dds.infrastructure.RETCODE_ERROR
    at com.rti.dds.util.Utilities.rethrow(Unknown Source)
    at com.rti.dds.infrastructure.RETCODE_ERROR.check_return_codeI(Unknown Source)
    at com.rti.dds.infrastructure.EntityImpl.enable(Unknown Source)
    at latency.LatencyPublisher.publisher_main(LatencyPublisher.java:165)
    at latency.LatencyPublisher.main(LatencyPublisher.java:42)

This is also happening when enabling the participant.

 

gianpiero's picture
Offline
Last seen: 1 year 6 months ago
Joined: 06/02/2010
Posts: 174

Hello,

Can you have a look to the answer given in this forum post? I believe that's what is happening in your experiment..

Let me know if that works! 

Best,
  Gianpiero Napoli

 

Offline
Last seen: 6 years 9 months ago
Joined: 10/10/2012
Posts: 24

I've increased the shmmem size to 1GB and doubled the semaphores, but it does not solve the problem. My guess would be, that the participant on my gateway is created as a default participant and has different settings than the RTI latency test. I will rewrite the latency sourcecode to use default participants as well, maybe that helps.