Updating from 5.1.0 to 5.3.1

2 posts / 0 new
Last post
Offline
Joined: 11/19/2018
Posts: 1
Updating from 5.1.0 to 5.3.1

Hello,

I'm trying to get this package compiled on my machine https://github.com/hengli/vmav-ros-pkg which states this requirement "RTI Connext DDS >= 5.1.0 (Source install to /opt)". I've managed to get RTI installed on my computer but then I ran into this bug https://github.com/hengli/vmav-ros-pkg/issues/4

It seems like the problem is this package: https://github.com/cvg/px-ros-pkg. I'm not too sure about the RTI library but I've been attempting to use the idl file to recreate the .cxx and .h files in the package by running `rtiddsgen DDSImage.idl -replace` and then moving the files to the correct folders.

After doing that though, the px-ros-pkg will build but the vmav-ros-pkg will still not build and the output looks strange on git diff. For example the namespace was removed and there is a "#using <new>".

Since I'm not familiar with this library, I am not sure how to update the package so that it can still be used. Would anyone be able to take a look at the output of the rtiddsgen command to see if there is anything obvious that I'm missing? https://github.com/mpitropov/px-ros-pkg/pull/1

Thanks in advance

 

Keywords:
Offline
Joined: 11/14/2017
Posts: 4

Just a guess here, but -- Can you determine what the original command-line options for rtiddsgen were, when this was built for v5.1.0?   

I suspect that one or more options should be included when using rtiddsgen to generate the code, such as: "-namespace", but there may be others needed.   
Try regenerating the code with this option, and see if it gets you closer to the original configuration.

The command-line options for the 5.3.1 release are in the current rtiddsgen user's manual,
and the ones for 5.1.0 are in the 5.1.0 Core Libs & Utils user's manual.