Blackberry QNX

1 post / 0 new
Offline
Last seen: 9 months 2 weeks ago
Joined: 05/09/2021
Posts: 5
QNX support: cmake modules changes related to cross compiling for multiarchitectures

There are a few issues with the cmake modules that help finding connext libraries for QNX

I have noticed that the new package rmw_connextdds has new cmake files that also search for connext installation, rti_connext_dds_cmake_module/cmake/rti_build_helper.cmake and the module that comes with host package rti_connext_dds-6.0.1/resource/cmake/FindRTIConnextDDS.cmake

Issue 1:

Organization:
4 posts / 0 new
Last post
Offline
Last seen: 9 months 2 weeks ago
Joined: 05/09/2021
Posts: 5
error message running connext rti 6.0.1 on QNX

When running ros2 on QNX with rmw_connext_cpp I get the following error message:

command:

ros2 run demo_nodes_cpp talker

Error message:

Organization:
Keywords:
2 posts / 0 new
Last post
Offline
Last seen: 9 months 2 weeks ago
Joined: 05/09/2021
Posts: 5
QNX 7.1 target for armv8

I noticed in the download section only rti_connext_dds-6.0.1.21-pro-target-x64QNX7.1qcc_cxx8.3.0.rtipkg and rti_connext_dds-6.0.1.21-pro-target-armv7QNX7.1qcc_cxx8.3.0.rtipkg but I cannot find rti_connext_dds-6.0.1.21-pro-target-armv8QNX7.1qcc_cxx8.3.0.rtipkg. Has armv8 not been made available yet?

Organization:
Subscribe to RSS - Blackberry QNX